Text message deliverability issues
Incident Report for Populi
Resolved
The carriers seem to have resolved this issue!
Posted May 19, 2022 - 01:44 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 18, 2022 - 17:16 PDT
Identified
Today we've noticed a large number of delivery errors for outgoing SMS messages - we're working with phone carriers to get this resolved, but unfortunately we can't predict how long that will take...
Posted May 18, 2022 - 17:15 PDT
This incident affected: SMS.