Populi logins aren't working for some users
Incident Report for Populi
Resolved
This incident has been resolved - it was a timezone bug and we'll do our best to make sure it doesn't happen next year!
Posted Mar 11, 2023 - 19:33 PST
Monitoring
Daylight savings time is tricky and apparently broke logins for a bit - everything appears to be back to normal but we're keeping an eye on things...
Posted Mar 11, 2023 - 19:14 PST
Investigating
We are currently investigating this issue.
Posted Mar 11, 2023 - 18:56 PST
This incident affected: Main Application.