Our datacenter successfully mitigated the attack and all systems are back to normal. Thanks for your patience!
Posted Feb 26, 2026 - 16:54 PST
Identified
Out primary datacenter is weathering a large DDOS attack... they're actively working to mitigate it and we'll continue to monitor.
Posted Feb 26, 2026 - 16:16 PST
Investigating
Our primary datacenter is experiencing network latency so Populi may appear to load slowly... we're in contact with their ops team and will post updates.
Posted Feb 26, 2026 - 15:44 PST
This incident affected: Main Application, API, Search, Media Encoding, Email, and SMS.